martedì 6 novembre 2012

Drivers ATI Radeon Legacy su Windows 8 e Windows 10

AGGIORNAMENTO: funziona anche su Windows 10.

Salve a tutti, ho appena installato Windows 8 Pro 64bit su un "vecchio" Acer Aspire con scheda video integrata radeon X1200... chiaramente Windows 8 non ha trovato i drivers automaticamente e ha sostituito la scheda video con una VGA standard.

Ho risolto così:

Il metodo dovrebbe funzionare con le schede seguenti:


ATI Radeon 9500 Series
ATI Radeon 9550 Series
ATI Radeon 9600 Series
ATI Radeon 9700 Series
ATI Radeon 9800 Series
ATI Radeon X300 Series
ATI Radeon X550 Series
ATI Radeon X600 Series
ATI Radeon X700 Series
ATI Radeon X800 Series
ATI Radeon X850 Series
ATI Radeon X1050 Series
ATI Radeon X1300 Series
ATI Radeon X1550 Series
ATI Radeon X1600 Series
ATI Radeon X1650 Series
ATI Radeon X1800 Series
ATI Radeon X1900 Series
ATI Radeon X1950 Series
ATI Radeon Xpress Series
ATI Radeon X1200 Series
ATI Radeon X1250 Series
ATI Radeon X2100 Series


Scaricate i drivers dal sito AMD





Procedete all'installazione in modo che il contenuto venga decompresso in

C:\ATI\Support\10-02_legacy_vista32-64_dd_ccc



Una volta scompattato tutto non continuate con l'installazione ma uscite cliccando su "Annulla".



Ora andate sull'angolo sinistro in basso dello schermo e cliccate tasto destro, apparirà un menù, cliccate su "Gestione Dispositivi".


Apparirà la classica finestra di gestione hardware di windows, andate su "Schede Video", troverete che Windows ha installato una generica scheda di base, cliccateci con il tasto destro e scegliete "Aggiornamento Software Driver":


A questo punto cliccate su "Cerca il software del driver nel computer":


Direzionate la ricerca nella cartella C:\ATI\Support\10-02_legacy_vista32-64_dd_ccc, mettete la spunta su "Includi Sottocartelle" e cliccate "Avanti":


Il sistema dovrebbe trovare i drivers per la vostra scheda video e installarli automaticamente.
Nel mio caso la scheda viene riconosciuta come "Radeon Xpress 1200 Series":
















14 commenti:

  1. Risposte
    1. Puoi indicare il modello della tua scheda grafica? Il metodo ha funzionato tranquillamente?

      Elimina
  2. Fantastico !!!!!

    Siete dei grandi !!!!!!!

    RispondiElimina
  3. Dopo tutta la letterartura varia che ho letto sul web questa, la più semplice, è quella che ha funzionato! GRAZIE!!!!!!!Q

    RispondiElimina
    Risposte
    1. La scheda è integrata in un vecchio HP Pavilion dv2-1010EL ed è una Ati Radeon X1270.

      Elimina
  4. Salve, io ho una x1650 e quando esegue installazione driver su windows 10 con questa modalità va in crash

    RispondiElimina
    Risposte
    1. prova questi: http://www.mediafire.com/download/stgd5pxbv4lk44p/ATI+Catalyst+12.11+B11+HotFix+11.09+V6+BETA.7z
      Installa normalmente dal setup, fai un'installazione personalizzata e rimuovi tutto il software che non serve (AVIVO e roba simile)

      Elimina
  5. ciao, io ho una x1650 e sono riuscito ad installare il driver su Win10.
    Il problema è che non essendo propriamente compatibile non funziona il Fast boot(che ho quindi disattivato) ma nemmeno la sospensione ibrida il che è un problema maggiore.
    Sei a conoscenza di qualche soluzione a questo problema? nel frattempo provo la versione beta che hai linkato.

    RispondiElimina
    Risposte
    1. prova a settare il login automatico con netplwiz e guarda se al reboot (con fastboot attivo) ti va a schermo nero. Nel pc del post alla fine ho risolto installando una scheda nvidia economica -> http://www.gigabyte.com/products/product-page.aspx?pid=4295#ov

      Elimina
    2. Ho provato la versione linkata, ma purtroppo i problemi sono rimasti gli stessi

      Elimina
    3. ho provato anche l'accesso automatico ma niente. Credo adotterò anche io la tua soluzione

      Elimina
  6. ti faccio l'ultima domanda anche se l'argomento non è inerente alla discussione. Togliendo sospensione ibrida e mettendo quella normale, il pc si addormenta, ma poi si sveglia subito(neanche 1 sec). Ho già disattivato a tutti i dispositivi (mouse tastiera e scheda di rete) la possibilità i riattivare il pc, ma continua a farlo.
    Tant'è che lanciando:
    powercfg -lastwake
    Conteggio cronologia riattivazioni - 1
    Cronologia riattivazioni [0]
    Conteggio origine riattivazione - 0

    powercfg -devicequery wake_armed
    NESSUNO

    Riesci ad aiutarmi?

    RispondiElimina